Leela not thinking enough time?

I purchased NCM pro but I don’t seem to be able to see much difference from free version other than being able to use some other hardware. Leela only thinks for like 5 seconds and stops. How do I choose longer thinking time? This is what I see with pro version, how can I choose the other settings talked about in the threads like thinking time etc…


This may be because of SmartPruningFactor. NCM leaves SmartPruningFactor at its default value (currently 1.33 according to Lc0 options - Leela Chess Zero) unless MultiPV is > 1. If MultiPV is > 1, then NCM sets SmartPruningFactor to 0.

So what you’re probably seeing is LcZero ending the search early because it determined that it can’t improve on its current result given the remaining time.

Do you have your think time maxed out at 30? Can you try setting MultiPV > 1 in settings (thereby disabling smart pruning) and see if that causes LcZero to search the full time?

Ah sorry my bad. I have just seen the settings icon now. Thank you.